Наш чат в Telegram для обмена идеями, проектами, мыслями, людьми в сфере ИТ г.Ростова-на-Дону: @it_rostov

RarEntry::getVersion

(PECL rar >= 0.1)

RarEntry::getVersion — Get minimum version of RAR program required to unpack the entry


Описание

public int RarEntry::getVersion ( void )

Returns minimum version of RAR program (e.g. WinRAR) required to unpack the entry. It is encoded as 10 * major version + minor version.


Список параметров

У этой функции нет параметров.


Возвращаемые значения

Returns the version or FALSE on error.


Примеры

Пример #1 RarEntry::getVersion() example
$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");
$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");
echo "Rar version required for unpacking: " . $entry->getVersion();


Описание класса rarentry, примеры использования класса rarentry.



Смотрите также:
Описание на ru2.php.net
Описание на php.ru